Browse Source

remove ffho-geo-location-whitespace-fix because it is upstream now

within master and 2016.1.x since Apr 28, 2016
Karsten Böddeker 8 years ago
parent
commit
76984b7686

+ 0 - 37
ffho/ffho-geo-location-whitespace-fix/Makefile

@@ -1,37 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-geo-location-whitespace-fix
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ffho-geo-location-whitespace-fix
-  SECTION:=ffho
-  CATEGORY:=Workarounds
-  TITLE:=Fixing whitespace errors at the geo-coordinates
-  DEPENDS:=+gluon-core
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-endef
-
-define Package/ffho-geo-location-whitespace-fix/description
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/ffho-geo-location-whitespace-fix/install
-  $(CP) ./files/* $(1)/
-endef
-
-$(eval $(call BuildPackage,ffho-geo-location-whitespace-fix))

+ 0 - 6
ffho/ffho-geo-location-whitespace-fix/ReadMe.md

@@ -1,6 +0,0 @@
-ffho-geo-location-whitespace-fix
-================================
-
-Within old versions of gluon it was possible to add whitespaces to the
-coordinates within config mode. This now leads to some errors. This package
-provides an upgrade script to delete the whitspaces.

+ 0 - 21
ffho/ffho-geo-location-whitespace-fix/files/lib/gluon/upgrade/900-geo-location-whitespace-fix

@@ -1,21 +0,0 @@
-#!/usr/bin/lua
-
-local uci = require('luci.model.uci').cursor()
-
-local sname = uci:get_first('gluon-node-info', 'location')
-if sname then
-  local latitude = uci:get('gluon-node-info', sname, 'latitude')
-  if latitude then
-    uci:set('gluon-node-info', sname, 'latitude', latitude:trim())
-  end
-  local longitude = uci:get('gluon-node-info', sname, 'longitude')
-  if longitude then
-    uci:set('gluon-node-info', sname, 'longitude', longitude:trim())
-  end
-  local altitude = uci:get('gluon-node-info', sname, 'altitude')
-  if altitude then
-    uci:set('gluon-node-info', sname, 'altitude', altitude:trim())
-  end
-  uci:save('gluon-node-info')
-  uci:commit('gluon-node-info')
-end