Browse Source

remove obsolete package ffho-alfred-watchdog

Karsten Böddeker 8 years ago
parent
commit
93f16bee5e

+ 0 - 50
ffho/ffho-alfred-watchdog/Makefile

@@ -1,50 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-alfred-watchdog
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ffho-alfred-watchdog
-  SECTION:=ffho
-  CATEGORY:=Workarounds
-  TITLE:=A.L.F.R.E.D. crash watchdog
-  DEPENDS:=+busybox
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-endef
-
-define Package/ffho-alfred-watchdog/description
-	Monitors whether or not the A.L.F.R.E.D. is still running on a node or
-	not. Version 2013.x crashes from time to time and thus some nodes dis-
-	appear from the map. It is thus suitable to monitor the state of the
-	daemon on the node itself by periodically making requests to avoid un-
-	necessary support-requests and manual restarts of these nodes. In a
-	failure state, the daemon can simply be restarted by triggering its
-	init-script.
-
-	Please note that the bug is most likely gone in v2014.1 and newer and
-	and thus the package does not need to be included in the firmware in
-	newer firmwares.
-endef
-
-define Build/Prepare
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/ffho-alfred-watchdog/install
-	$(INSTALL_DIR) $(1)/bin/
-	$(INSTALL_DIR) $(1)/lib/gluon/cron/
-	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
-	$(INSTALL_DATA) ./files/lib/gluon/cron/* $(1)/lib/gluon/cron/
-endef
-
-$(eval $(call BuildPackage,ffho-alfred-watchdog))

+ 0 - 4
ffho/ffho-alfred-watchdog/ReadMe.md

@@ -1,4 +0,0 @@
-ffho-alfred-watchdog
-====================
-
-*OBSOLETE*

+ 0 - 21
ffho/ffho-alfred-watchdog/files/bin/ffho-alfred-watchdog

@@ -1,21 +0,0 @@
-#!/bin/sh
-
-LOCK_FILE="/tmp/.alfred_watchdog_lock"
-ALFRED_MAJOR_VERSION=`/usr/sbin/alfred --version | awk 'NR==1{print substr($0,18,4)};'`
-
-[[ -e ${LOCK_FILE} ]] && exit 0;
-
-/bin/touch ${LOCK_FILE}
-
-rand=`tr -cd 0-9 </dev/urandom | head -c 32`
-delay=`expr ${rand} % 55`
-#sleep ${delay}m
-
-/usr/sbin/alfred -b bat0 -r 158 > /dev/null 2&>1
-if [[ "$?" == 255 ]] ; then
-    logger -s -t ffho-alfred-watchdog -p local0.info "A.L.F.R.E.D. appears to be dead. Triggering a restart now."
-    /etc/init.d/alfred restart > /dev/null 2&>1
-    [[ "$ALFRED_MAJOR_VERSION" -gt 2013 ]] && /bin/ffho-debug > /dev/null 2&>1
-fi
-
-[[ -e ${LOCK_FILE} ]] && /bin/rm ${LOCK_FILE}

+ 0 - 1
ffho/ffho-alfred-watchdog/files/lib/gluon/cron/ffho-alfred-watchdog

@@ -1 +0,0 @@
-55 * * * * /bin/ffho-alfred-watchdog