Bläddra i källkod

Changes Makefile of ffpb-debug to make use of OpenWRT INSTALL_{DIR,
DATA, BIN} macros.

Using these macros (instead of $(CP)) in the Package/.../install section
ensures correct permissions of the files installed in the image.
The two scripts ffpb-debug and ffpb-debug now get installed using
INSTALL_BIN, while the (orphaned) cron-file gets installed using
INSTALL_DATA. In both cases we ensure that the directories exist by
calling INSTALL_DIR (with parameters "/bin" and "/lib/gluon/cron"
respectively) prior to installing the files.

Stefan Laudemann 9 år sedan
förälder
incheckning
e056bf77ec
1 ändrade filer med 4 tillägg och 1 borttagningar
  1. 4 1
      ffpb/ffpb-debug/Makefile

+ 4 - 1
ffpb/ffpb-debug/Makefile

@@ -30,7 +30,10 @@ define Build/Compile
 endef
 
 define Package/ffpb-debug/install
-	$(CP) ./files/* $(1)/
+	$(INSTALL_DIR) $(1)/bin/
+	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
+	$(INSTALL_DIR) $(1)/lib/gluon/cron/
+	$(INSTALL_DATA) ./files/lib/gluon/cron/* $(1)/lib/gluon/cron/
 endef
 
 $(eval $(call BuildPackage,ffpb-debug))