Browse Source

Makes Makefile use the $(CP) makro instead of $(INSTALL_BIN) for "library"-functions shell scripts.

As '/lib/netifd/hostapd.sh' and '/lib/wifi/mac80211.sh' should never be
called directly (but only be included from other files like '/lib/netifd/
wireless/mac80211.sh', these files do not need to have an execute bit
set, which on the other hand would be ensured by using the
$(INSTALL_BIN) macro in the make file. The $(CP) macro would simply copy
the files from the package into the image and preserve their
permissions.

Signed-off-by: Stefan Laudemann <thisco@webcake.de>
Stefan Laudemann 9 years ago
parent
commit
d849dd8d4c
1 changed files with 2 additions and 2 deletions
  1. 2 2
      ffpb/ffpb-openwrt-migration-tools/Makefile

+ 2 - 2
ffpb/ffpb-openwrt-migration-tools/Makefile

@@ -58,8 +58,8 @@ define Package/ffpb-openwrt-migration-tools/install
 	$(INSTALL_BIN) ./files/etc/uci-defaults/90-tlwr1043ndv2-autoupdater-to-stable $(1)/etc/uci-defaults/
 	$(INSTALL_BIN) ./files/etc/uci-defaults/40-wireless-config-hwmode-fix $(1)/etc/uci-defaults/
 	$(INSTALL_BIN) ./files/lib/netifd/wireless/mac80211.sh $(1)/lib/netifd/wireless/
-	$(INSTALL_BIN) ./files/lib/netifd/hostapd.sh $(1)/lib/netifd/
-	$(INSTALL_BIN) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi/
+	$(CP) ./files/lib/netifd/hostapd.sh $(1)/lib/netifd/
+	$(CP) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi/
 endef
 
 $(eval $(call BuildPackage,ffpb-openwrt-migration-tools))