Przeglądaj źródła

standardize Makefiles

Karsten Böddeker 8 lat temu
rodzic
commit
aec0976935

+ 2 - 3
ffho/ffho-alfred-watchdog/Makefile

@@ -10,12 +10,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-alfred-watchdog
   SECTION:=ffho
-  CATEGORY:=workarounds
+  CATEGORY:=Workarounds
   TITLE:=A.L.F.R.E.D. crash watchdog
   DEPENDS:=+busybox
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-alfred-watchdog/description

+ 2 - 6
ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile

@@ -10,12 +10,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-autoupdater-wifi-fallback-legacy
   SECTION:=ffho
-  CATEGORY:=Gluon
+  CATEGORY:=Workarounds
   TITLE:=Toolset of scripts for migration of ffho-autoupdater-wifi-fallback.
   DEPENDS:=+ffho-autoupdater-wifi-fallback
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-autoupdater-wifi-fallback-legacy/description
@@ -33,9 +32,6 @@ endef
 define Build/Compile
 endef
 
-define Package/ffho-autoupdater-wifi-fallback-legacy/preinst
-endef
-
 define Package/ffho-autoupdater-wifi-fallback-legacy/install
   $(CP) ./files/* $(1)/
 endef

+ 6 - 4
ffho/ffho-autoupdater-wifi-fallback/Makefile

@@ -1,17 +1,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffho-autoupdater-wifi-fallback
-PKG_VERSION:=1
+PKG_VERSION:=2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-autoupdater-wifi-fallback
-  SECTION:=admin
-  CATEGORY:=Administration
-  DEPENDS:=+iwinfo +wpa-supplicant-mini +gluon-autoupdater
+  SECTION:=ffho
+  CATEGORY:=FFHO
   TITLE:=Implements switching to fallback mode if we are cut off from the mesh
+  DEPENDS:=+iwinfo +wpa-supplicant-mini +gluon-autoupdater
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Build/Prepare

+ 4 - 2
ffho/ffho-autoupdater/Makefile

@@ -12,9 +12,11 @@ include $(GLUONDIR)/include/package.mk
 define Package/ffho-autoupdater
   SECTION:=ffho
   CATEGORY:=Gluon
-  DEPENDS:=+gluon-core +libgluonutil +micrond +autoupdater
   TITLE:=Automatically update firmware
+  DEPENDS:=+gluon-core +libgluonutil +micrond +autoupdater
   PROVIDES:=gluon-autoupdater
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Build/Prepare
@@ -39,4 +41,4 @@ define Package/ffho-autoupdater/postinst
 $(call GluonCheckSite,check_site.lua)
 endef
 
-$(eval $(call BuildPackage,ffho-autoupdater))
+$(eval $(call BuildPackage,ffho-autoupdater))

+ 2 - 3
ffho/ffho-banner/Makefile

@@ -10,12 +10,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-banner
   SECTION:=ffho
-  CATEGORY:=Customization
+  CATEGORY:=FFHO
   TITLE:=Banner file replacement
   DEPENDS:=+gluon-core +busybox
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@hochstift.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-banner/description

+ 3 - 1
ffho/ffho-config-mode-geo-location/Makefile

@@ -11,11 +11,13 @@ PKG_CONFIG_DEPENDS += $(GLUON_I18N_CONFIG)
 
 
 define Package/ffho-config-mode-geo-location
-  SECTION:=gluon
+  SECTION:=ffho
   CATEGORY:=Gluon
   TITLE:=Set geographic location of a node
   DEPENDS:=gluon-config-mode-core-virtual +gluon-node-info
   PROVIDES:=gluon-config-mode-geo-location
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Build/Prepare

+ 3 - 1
ffho/ffho-config-mode-mesh-vpn/Makefile

@@ -11,11 +11,13 @@ PKG_CONFIG_DEPENDS += $(GLUON_I18N_CONFIG)
 
 
 define Package/ffho-config-mode-mesh-vpn
-  SECTION:=gluon
+  SECTION:=ffho
   CATEGORY:=Gluon
   TITLE:=Toggle mesh-vpn and bandwidth limit
   DEPENDS:=gluon-config-mode-core-virtual +gluon-mesh-vpn-fastd
   PROVIDES:=gluon-config-mode-mesh-vpn
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Build/Prepare

+ 4 - 2
ffho/ffho-config-mode-site-select/Makefile

@@ -11,10 +11,12 @@ include $(INCLUDE_DIR)/package.mk
 PKG_CONFIG_DEPENDS += $(GLUON_I18N_CONFIG)
 
 define Package/ffho-config-mode-site-select
-  SECTION:=gluon
-  CATEGORY:=Gluon
+  SECTION:=ffho
+  CATEGORY:=Site-select
   TITLE:=UI for changing the node-config
   DEPENDS:=+gluon-config-mode-core-virtual +ffho-site-generate
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Build/Prepare

+ 2 - 3
ffho/ffho-debug/Makefile

@@ -10,12 +10,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-debug
   SECTION:=ffho
-  CATEGORY:=debug
+  CATEGORY:=FFHO
   TITLE:=Debug scripts for Freifunk Hochstift
   DEPENDS:=+gluon-core +ubus +libubox +busybox
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-debug/description

+ 2 - 3
ffho/ffho-ebtables-net-rules/Makefile

@@ -10,12 +10,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-ebtables-net-rules
   SECTION:=ffho
-  CATEGORY:=Gluon
+  CATEGORY:=FFHO
   TITLE:=FFHO net-specific ebtables rules to filter unreasonable L2 traffic.
   DEPENDS:=+gluon-core +gluon-ebtables
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-ebtables-net-rules/description

+ 2 - 6
ffho/ffho-node-tuning/Makefile

@@ -10,12 +10,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-node-tuning
   SECTION:=ffho
-  CATEGORY:=Gluon
+  CATEGORY:=FFHO
   TITLE:=Freifunk Hochstift Node Tuning-Settings
   DEPENDS:=+gluon-core +busybox
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-node-tuning/description
@@ -38,9 +37,6 @@ endef
 define Build/Compile
 endef
 
-define Package/ffho-node-tuning/postinst
-endef
-
 define Package/ffho-node-tuning/install
 	$(INSTALL_DIR) $(1)/lib/gluon/upgrade/
 	$(INSTALL_BIN) ./files//lib/gluon/upgrade/* $(1)/lib/gluon/upgrade/

+ 1 - 2
ffho/ffho-respondd-config/Makefile

@@ -11,12 +11,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-respondd-config
   SECTION:=ffho
-  CATEGORY:=workarounds
+  CATEGORY:=FFHO
   TITLE:=Additional respondd config files 
   DEPENDS:=+gluon-core +libgluonutil
   MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-respondd-config/description

+ 2 - 6
ffho/ffho-site-auto-select/Makefile

@@ -12,12 +12,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-site-auto-select
   SECTION:=ffho
-  CATEGORY:=Gluon
+  CATEGORY:=Site-select
   TITLE:=Toolset to autodetect the site.
   DEPENDS:=+gluon-core +micrond +gluon-neighbour-info +ffho-site-generate
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-site-auto-select/description
@@ -34,9 +33,6 @@ endef
 define Build/Compile
 endef
 
-define Package/ffho-site-auto-select/preinst
-endef
-
 define Package/ffho-site-auto-select/install
 	$(CP) ./files/* $(1)/
 	$(INSTALL_DIR) $(1)/lib/gluon/site-select

+ 2 - 6
ffho/ffho-site-generate/Makefile

@@ -12,12 +12,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-site-generate
   SECTION:=ffho
-  CATEGORY:=Gluon
+  CATEGORY:=Site-select
   TITLE:=Scripts for generating a new site.json
   DEPENDS:=+gluon-core +luci-lib-json
-  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
   URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 
 define Package/ffho-site-generate/description
@@ -33,9 +32,6 @@ endef
 define Build/Compile
 endef
 
-define Package/ffho-site-generate/preinst
-endef
-
 define Package/ffho-site-generate/install
 	$(CP) ./files/* $(1)/
 	lua -e 'print(require("cjson").encode(assert(dofile("$(GLUONDIR)/scripts/site_config.lua"))))' > $(1)/lib/gluon/site-select/default.json

+ 2 - 0
ffho/ffho-status-page/Makefile

@@ -14,6 +14,8 @@ define Package/ffho-status-page
   TITLE:=Adds a status page showing information about the node.
   DEPENDS:=+gluon-core +uhttpd +gluon-neighbour-info +gluon-respondd +libiwinfo-lua +luci-lib-jsonc
   PROVIDES:=gluon-status-page
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Package/ffho-status-page/description

+ 6 - 4
ffho/ffho-txpower-fix/Makefile

@@ -8,10 +8,12 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-txpower-fix
-  SECTION:=admin
-  CATEGORY:=Workaround
-  DEPENDS:=+wireless-tools
-  TITLE:=Fixes txpower on some wifi nodes under chaos calmer (gluon 2015.2)
+  SECTION:=ffho
+  CATEGORY:=Workarounds
+  TITLE:=Fixes txpower on some wifi nodes under chaos calmer (gluon 2016.1.x)
+  DEPENDS:=+gluon-core
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Package/ffho-txpower-fix/description

+ 3 - 1
ffho/ffho-wifi-blackout-workaround/Makefile

@@ -10,9 +10,11 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-wifi-blackout-workaround
   SECTION:=ffho
-  CATEGORY:=workarounds
+  CATEGORY:=Workarounds
   TITLE:=WiFi-Blackout workaround
   DEPENDS:=+gluon-core
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Package/ffho-wifi-blackout-workaround/description

+ 6 - 3
ffho/ffho-wifi-mesh-macfilter/Makefile

@@ -10,17 +10,20 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ffho-wifi-mesh-macfilter
   SECTION:=ffho
-  CATEGORY:=workarounds
+  CATEGORY:=Workarounds
   TITLE:=WiFi - block/open 802.11s-mesh stations
   DEPENDS:=+iw +uci
+  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
 endef
 
 define Package/ffho-wifi-mesh-macfilter/description
 	Setting plink_action [block|open], when 802.11s mesh-interface comes up.
 	Define filterpolicy in uci wireless.<wifi-iface>.macfilter=[disable|deny|allow].
 	Deny sets iw dev <device> station set <mac> plink_action block, and
-	allow sets iw dev <device> mesh_param mesh_auto_open_plink=0 and iw dev <device> station set <mac> plink_action open.
-	List MAC adresses (divided by spaces) in uci wireless.<wifi-iface>.maclist.
+	allow sets iw dev <device> mesh_param mesh_auto_open_plink=0 and
+	iw dev <device> station set <mac> plink_action open. List MAC adresses
+	(divided by spaces) in uci wireless.<wifi-iface>.maclist.
 endef
 
 define Build/Prepare