Browse Source

Some cosmetic changes in the makefiles

Michael Schwarz 5 years ago
parent
commit
9a682395af

+ 1 - 17
ffho-ap-timer/Makefile

@@ -19,20 +19,4 @@ define Package/ffho-ap-timer/description
 	Timer for the client wifi
 endef
 
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-ap-timer/install
-	$(CP) ./files/* $(1)/
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-endef
-
-$(eval $(call BuildPackage,ffho-ap-timer))
+$(eval $(call BuildPackageGluon,$(PKG_NAME)))

+ 1 - 17
ffho-ath9k-blackout-workaround/Makefile

@@ -19,25 +19,9 @@ define Package/ffho-ath9k-blackout-workaround/description
 	Restartes the wifi if possible blckout is detected.
 endef
 
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-ath9k-blackout-workaround/install
-	$(CP) ./files/* $(1)/
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-endef
-
 define Package/ffho-ath9k-blackout-workaround/postinst
 #!/bin/sh
 $(call GluonCheckSite,check_site.lua)
 endef
 
-$(eval $(call BuildPackage,ffho-ath9k-blackout-workaround))
+$(eval $(call BuildPackageGluon,$(PKG_NAME)))

+ 1 - 19
ffho-autoupdater-wifi-fallback/Makefile

@@ -16,22 +16,4 @@ define Package/ffho-autoupdater-wifi-fallback
   MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
 endef
 
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-	$(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
-	$(call Build/Compile/Default)
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-autoupdater-wifi-fallback/install
-	$(CP) ./files/* $(1)/
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-
-	$(INSTALL_DIR) $(1)/lib/gluon/respondd
-	$(CP) $(PKG_BUILD_DIR)/respondd.so $(1)/lib/gluon/respondd/autoupdater-wifi-fallback.so
-endef
-
-$(eval $(call BuildPackage,ffho-autoupdater-wifi-fallback))
+$(eval $(call BuildPackageGluon,$(PKG_NAME)))

+ 1 - 16
ffho-debug/Makefile

@@ -19,19 +19,4 @@ define Package/ffho-debug/description
 	Debug scripts for FFHO
 endef
 
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-debug/install
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-endef
-
-$(eval $(call BuildPackage,ffho-debug))
+$(eval $(call BuildPackageGluon,$(PKG_NAME)))

+ 1 - 16
ffho-domain-migration/Makefile

@@ -19,24 +19,9 @@ define Package/ffho-domain-migration/description
 	Migration script for gluon multidomain support
 endef
 
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-domain-migration/install
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-endef
-
 define Package/ffho-domain-migration/postinst
 #!/bin/sh
 $(call GluonCheckSite,check_site.lua)
 endef
 
-$(eval $(call BuildPackage,ffho-domain-migration))
+$(eval $(call BuildPackageGluon,$(PKG_NAME)))