Просмотр исходного кода

Fix Makefile dependencies
adding PROVIDES:=gluon-* to corresponding ffho-package

Karsten Böddeker 8 лет назад
Родитель
Сommit
6ab5b2c6e8

+ 1 - 0
ffho/ffho-config-mode-geo-location/Makefile

@@ -15,6 +15,7 @@ define Package/ffho-config-mode-geo-location
   CATEGORY:=Gluon
   TITLE:=Set geographic location of a node
   DEPENDS:=gluon-config-mode-core-virtual +gluon-node-info
+  PROVIDES:=gluon-config-mode-geo-location
 endef
 
 define Build/Prepare

+ 2 - 1
ffho/ffho-config-mode-mesh-vpn/Makefile

@@ -15,6 +15,7 @@ define Package/ffho-config-mode-mesh-vpn
   CATEGORY:=Gluon
   TITLE:=Toggle mesh-vpn and bandwidth limit
   DEPENDS:=gluon-config-mode-core-virtual +gluon-mesh-vpn-fastd
+  PROVIDES:=gluon-config-mode-mesh-vpn
 endef
 
 define Build/Prepare
@@ -33,4 +34,4 @@ define Package/ffho-config-mode-mesh-vpn/install
 	$(call GluonInstallI18N,ffho-config-mode-mesh-vpn,$(1))
 endef
 
-$(eval $(call BuildPackage,ffho-config-mode-mesh-vpn))
+$(eval $(call BuildPackage,ffho-config-mode-mesh-vpn))

+ 1 - 0
ffho/ffho-status-page/Makefile

@@ -13,6 +13,7 @@ define Package/ffho-status-page
   CATEGORY:=Gluon
   TITLE:=Adds a status page showing information about the node.
   DEPENDS:=+gluon-core +uhttpd +gluon-neighbour-info +gluon-respondd +libiwinfo-lua +luci-lib-jsonc
+  PROVIDES:=gluon-status-page
 endef
 
 define Package/ffho-status-page/description