Browse Source

drop a bunch of packages

ffho-autoupdater-wifi-fallback-legacy: obsolete
ffho-ebtables-net-rules: moved upstream (gluon-ebtables-source-filter)
fho-fix-defaultroute: obsolete, was just a fix for some old firmware versions
ffho-geo-location-altitude-delete: no longer used
ffho-luci-remote-syslog: moved upstream (gluon-web-logging)
ffho-respondd-config: not needed for meshviewer
Karsten Böddeker 6 years ago
parent
commit
69d08893e8
25 changed files with 0 additions and 438 deletions
  1. 0 39
      ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile
  2. 0 5
      ffho/ffho-autoupdater-wifi-fallback-legacy/ReadMe.md
  3. 0 7
      ffho/ffho-autoupdater-wifi-fallback-legacy/luasrc/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy
  4. 0 43
      ffho/ffho-ebtables-net-rules/Makefile
  5. 0 26
      ffho/ffho-ebtables-net-rules/ReadMe.md
  6. 0 1
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/100-ffho-net-chain
  7. 0 7
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv4-space
  8. 0 9
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv6-spaces
  9. 0 1
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/400-add-ffho-net-chain
  10. 0 33
      ffho/ffho-fix-defaultroute/Makefile
  11. 0 4
      ffho/ffho-fix-defaultroute/ReadMe.md
  12. 0 2
      ffho/ffho-fix-defaultroute/files/lib/gluon/upgrade/109-fix-defaultroute
  13. 0 37
      ffho/ffho-geo-location-altitude-delete/Makefile
  14. 0 5
      ffho/ffho-geo-location-altitude-delete/ReadMe.md
  15. 0 10
      ffho/ffho-geo-location-altitude-delete/luasrc/lib/gluon/upgrade/900-geo-location-altitude-delete
  16. 0 38
      ffho/ffho-luci-remote-syslog/Makefile
  17. 0 4
      ffho/ffho-luci-remote-syslog/ReadMe.md
  18. 0 10
      ffho/ffho-luci-remote-syslog/i18n/de.po
  19. 0 8
      ffho/ffho-luci-remote-syslog/i18n/ffho-luci-remote-syslog.pot
  20. 0 5
      ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/controller/admin/remote-syslog.lua
  21. 0 22
      ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua
  22. 0 34
      ffho/ffho-respondd-config/Makefile
  23. 0 19
      ffho/ffho-respondd-config/ReadMe.md
  24. 0 6
      ffho/ffho-respondd-config/src/Makefile
  25. 0 63
      ffho/ffho-respondd-config/src/respondd.c

+ 0 - 39
ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile

@@ -1,39 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-autoupdater-wifi-fallback-legacy
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/../package/gluon.mk
-
-define Package/ffho-autoupdater-wifi-fallback-legacy
-  SECTION:=ffho
-  CATEGORY:=Workarounds
-  TITLE:=Toolset of scripts for migration of ffho-autoupdater-wifi-fallback.
-  DEPENDS:=+ffho-autoupdater-wifi-fallback
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-endef
-
-define Package/ffho-autoupdater-wifi-fallback-legacy/description
-	A collection of scripts that fix and cleanup configurations off
-	ffho-autoupdater-wifi-fallback on a node when upgrading the firmware.
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-autoupdater-wifi-fallback-legacy/install
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-endef
-
-$(eval $(call BuildPackage,ffho-autoupdater-wifi-fallback-legacy))

+ 0 - 5
ffho/ffho-autoupdater-wifi-fallback-legacy/ReadMe.md

@@ -1,5 +0,0 @@
-ffho-autoupdater-wifi-fallback-legacy
-=====================================
-
-Only needed to upgrade the configuration from an old version of
-`ffho-autoupdater-wifi-fallback` to the current on.

+ 0 - 7
ffho/ffho-autoupdater-wifi-fallback-legacy/luasrc/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy

@@ -1,7 +0,0 @@
-#!/usr/bin/lua
-local uci = require('luci.model.uci').cursor()
-
-if uci:get('autoupdater-wifi-fallback','settings') and uci:get('autoupdater-wifi-fallback','settings','min_uptime_secs') then
-  uci:delete('autoupdater-wifi-fallback','settings')
-  uci:save('autoupdater-wifi-fallback')
-end

+ 0 - 43
ffho/ffho-ebtables-net-rules/Makefile

@@ -1,43 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-ebtables-net-rules
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/../package/gluon.mk
-
-define Package/ffho-ebtables-net-rules
-  SECTION:=ffho
-  CATEGORY:=FFHO
-  TITLE:=FFHO net-specific ebtables rules to filter unreasonable L2 traffic.
-  DEPENDS:=+gluon-core +gluon-ebtables
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-endef
-
-define Package/ffho-ebtables-net-rules/description
-	This package adds an additional layer-2 filter-ruleset to prevent traffic,
-	which is not destined for any Freifunk Paderborn layer-3 specific target,
-	from entering the network via the nodes.
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/ffho-ebtables-net-rules/install
-	$(INSTALL_DIR) $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/100-ffho-net-chain $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/110-ffho-net-allow-ipv4-space $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/110-ffho-net-allow-ipv6-spaces $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/400-add-ffho-net-chain $(1)/lib/gluon/ebtables/
-endef
-
-$(eval $(call BuildPackage,ffho-ebtables-net-rules))

+ 0 - 26
ffho/ffho-ebtables-net-rules/ReadMe.md

@@ -1,26 +0,0 @@
-ffho-ebtables-net-rules
-=======================
-
-Additional ebtables rules for Freifunk-Nodes
-
-site.conf
----------
-
-**prefix4:**
-- IPv4 prefix
-
-**prefix6:**
-- IPv6 prefix
-
-**additional_prefix6: optional**
-- list of additional IPv6 prefix
-
-### example
-```lua
-{
-  prefix4 = '10.132.0.0./18',
-  prefix6 = 'fdca:ffee:ff12:132::/64',
-  additional_prefix6 = { '2a03:2260:2342:2300::/64' },
-  ...
-},
-```

+ 0 - 1
ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/100-ffho-net-chain

@@ -1 +0,0 @@
-chain('FFHO_NET_ONLY', 'DROP')

+ 0 - 7
ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv4-space

@@ -1,7 +0,0 @@
-siteConfig = require("gluon.site_config")
-prefix4 = siteConfig.prefix4
-
-rule ('FFHO_NET_ONLY -p IPv4 --ip-protocol udp --ip-destination-port 67 -j RETURN')
-rule ('FFHO_NET_ONLY -p IPv4 --ip-src ' .. prefix4 .. ' -j RETURN')
-rule ('FFHO_NET_ONLY -p ARP --arp-ip-src ' .. prefix4 .. ' --arp-ip-dst ' .. prefix4 .. ' -j RETURN')
-rule ('FFHO_NET_ONLY -p ARP --arp-ip-src 0.0.0.0/0 --arp-ip-dst ' .. prefix4 .. ' -j RETURN')

+ 0 - 9
ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv6-spaces

@@ -1,9 +0,0 @@
-siteConfig = require("gluon.site_config")
-
-rule ('FFHO_NET_ONLY -p IPv6 --ip6-src fe80::/10 -j RETURN')
-rule ('FFHO_NET_ONLY -p IPv6 --ip6-dst ff00::/8 -j RETURN')
-rule ('FFHO_NET_ONLY -p IPv6 --ip6-src ' .. siteConfig.prefix6 .. ' -j RETURN')
-
-for _, prefix in ipairs(siteConfig.additional_prefix6) do
-	rule ('FFHO_NET_ONLY -p IPv6 --ip6-src ' .. prefix .. ' -j RETURN')
-end

+ 0 - 1
ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/400-add-ffho-net-chain

@@ -1 +0,0 @@
-rule 'FORWARD --logical-in br-client -i ! bat0 -j FFHO_NET_ONLY'

+ 0 - 33
ffho/ffho-fix-defaultroute/Makefile

@@ -1,33 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-fix-defaultroute
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/../package/gluon.mk
-
-define Package/ffho-fix-defaultroute
-  SECTION:=ffho
-  CATEGORY:=FFHO
-  TITLE:=Freifunk Hochstift fix Defaultroute
-  DEPENDS:=+gluon-core
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/ffho-fix-defaultroute/install
-	$(CP) ./files/* $(1)/
-endef
-
-$(eval $(call BuildPackage,ffho-fix-defaultroute))

+ 0 - 4
ffho/ffho-fix-defaultroute/ReadMe.md

@@ -1,4 +0,0 @@
-ffho-fix-defaultroute
-=====================
-
-Script to fix `'network.client.defaultroute='0'`, which was set by some older firmware.

+ 0 - 2
ffho/ffho-fix-defaultroute/files/lib/gluon/upgrade/109-fix-defaultroute

@@ -1,2 +0,0 @@
-#!/bin/sh
-uci -q delete network.client.defaultroute

+ 0 - 37
ffho/ffho-geo-location-altitude-delete/Makefile

@@ -1,37 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-geo-location-altitude-delete
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/../package/gluon.mk
-
-define Package/ffho-geo-location-altitude-delete
-  SECTION:=ffho
-  CATEGORY:=Workarounds
-  TITLE:=Deleting the altitude value of the geo location
-  DEPENDS:=+gluon-core
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-endef
-
-define Package/ffho-geo-location-altitude-delete/description
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-geo-location-altitude-delete/install
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-endef
-
-$(eval $(call BuildPackage,ffho-geo-location-altitude-delete))

+ 0 - 5
ffho/ffho-geo-location-altitude-delete/ReadMe.md

@@ -1,5 +0,0 @@
-ffho-geo-location-altitude-delete
-=================================
-
-As the usage of the altitude is not well defined this package provides an
-upgrade script to delete the altitude value if already set.

+ 0 - 10
ffho/ffho-geo-location-altitude-delete/luasrc/lib/gluon/upgrade/900-geo-location-altitude-delete

@@ -1,10 +0,0 @@
-#!/usr/bin/lua
-
-local uci = require('luci.model.uci').cursor()
-
-local sname = uci:get_first("gluon-node-info", "location")
-local altitude = uci:get("gluon-node-info", sname, "altitude")
-if altitude ~= nil then
-  uci:delete("gluon-node-info", sname, "altitude")
-  uci:save("gluon-node-info")
-end

+ 0 - 38
ffho/ffho-luci-remote-syslog/Makefile

@@ -1,38 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-luci-remote-syslog
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/../package/gluon.mk
-
-PKG_CONFIG_DEPENDS += $(GLUON_I18N_CONFIG)
-
-define Package/ffho-luci-remote-syslog
-  SECTION:=ffho
-  CATEGORY:=FFHO
-  TITLE:=Luci module for setting a remote syslog server
-  DEPENDS:=+gluon-luci-admin
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call GluonBuildI18N,ffho-luci-remote-syslog,i18n)
-	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
-endef
-
-define Package/ffho-luci-remote-syslog/install
-	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
-	$(call GluonInstallI18N,ffho-luci-remote-syslog,$(1))
-endef
-
-$(eval $(call BuildPackage,ffho-luci-remote-syslog))

+ 0 - 4
ffho/ffho-luci-remote-syslog/ReadMe.md

@@ -1,4 +0,0 @@
-ffho-luci-remote-syslog
-=======================
-
-Luci module for setting a remote syslog server.

+ 0 - 10
ffho/ffho-luci-remote-syslog/i18n/de.po

@@ -1,10 +0,0 @@
-msgid ""
-msgstr "Content-Type: text/plain; charset=UTF-8"
-
-msgid "If you want to use a remote syslog server, you can set it up here."
-msgstr ""
-"Wenn du einen Remote-Syslog-Server nutzen möchtest, dann kannst du ihn hier "
-"eintragen."
-
-msgid "Remote Syslog"
-msgstr "Remote-Syslog"

+ 0 - 8
ffho/ffho-luci-remote-syslog/i18n/ffho-luci-remote-syslog.pot

@@ -1,8 +0,0 @@
-msgid ""
-msgstr "Content-Type: text/plain; charset=UTF-8"
-
-msgid "If you want to use a remote syslog server, you can set it up here."
-msgstr ""
-
-msgid "Remote Syslog"
-msgstr ""

+ 0 - 5
ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/controller/admin/remote-syslog.lua

@@ -1,5 +0,0 @@
-module("luci.controller.admin.remote-syslog", package.seeall)
-
-function index()
-        entry({"admin", "remote-syslog"}, cbi("admin/remote-syslog"), _("Remote Syslog"), 85)
-end

+ 0 - 22
ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua

@@ -1,22 +0,0 @@
-m = Map("system", translate("Remote Syslog"), translate(
-  "If you want to use a remote syslog server, you can set it up here."))
-m.pageaction = false
-m.template = "cbi/simpleform"
-
-s = m:section(TypedSection, "system", nil)
-s.addremove = false
-s.anonymous = true
-
-o = s:option(Flag, "log_remote", translate("Enable"))
-o.rmempty = false
-
-o = s:option(Value, "log_ip", translate("IP"))
-o.placeholder = "0.0.0.0"
-o.datatype = "ipaddr"
-
-o = s:option(Value, "log_port", translate("Port"))
-o.placeholder = 514
-o.datatype = "port"
-
-return m
-

+ 0 - 34
ffho/ffho-respondd-config/Makefile

@@ -1,34 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffho-respondd-config
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-PKG_BUILD_DEPENDS := respondd
-
-include $(TOPDIR)/../package/gluon.mk
-
-define Package/ffho-respondd-config
-  SECTION:=ffho
-  CATEGORY:=FFHO
-  TITLE:=Additional respondd config files
-  DEPENDS:=+gluon-core +libgluonutil
-  MAINTAINER:=Freifunk Hochstift <kontakt@hochstift.freifunk.net>
-endef
-
-define Package/ffho-respondd-config/description
-  This package contains additional config files for respondd
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-	$(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Package/ffho-respondd-config/install
-	$(INSTALL_DIR) $(1)/lib/gluon/respondd
-	$(CP) $(PKG_BUILD_DIR)/respondd.so $(1)/lib/gluon/respondd/ffho.so
-endef
-
-$(eval $(call BuildPackage,ffho-respondd-config))

+ 0 - 19
ffho/ffho-respondd-config/ReadMe.md

@@ -1,19 +0,0 @@
-ffho-respondd-config
-====================
-
-Package for customization of respondd data. Actually this adds the `site_name`
-to data transmitted by respondd.
-
-site.conf
----------
-
-**site_name:**
-- The name of your community
-
-### example
-```lua
-{
-  site_name = 'Freifunk Hochstift',
-  ...
-},
-```

+ 0 - 6
ffho/ffho-respondd-config/src/Makefile

@@ -1,6 +0,0 @@
-all: respondd.so
-
-CFLAGS += -Wall
-
-respondd.so: respondd.c
-	$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -shared -fPIC -D_GNU_SOURCE -o $@ $^ $(LDLIBS) -lgluonutil -luci

+ 0 - 63
ffho/ffho-respondd-config/src/respondd.c

@@ -1,63 +0,0 @@
-/*
-  Copyright (c) 2016, Matthias Schiffer <mschiffer@universe-factory.net>
-  Copyright (c) 2016, Karsten Böddeker <freifunk@kb-light.de>
-
-  All rights reserved.
-
-  Redistribution and use in source and binary forms, with or without
-  modification, are permitted provided that the following conditions are met:
-
-    1. Redistributions of source code must retain the above copyright notice,
-       this list of conditions and the following disclaimer.
-    2. Redistributions in binary form must reproduce the above copyright notice,
-       this list of conditions and the following disclaimer in the documentation
-       and/or other materials provided with the distribution.
-
-  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-  AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-  IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-  DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-  FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-  DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-  SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-  CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-  OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-*/
-
-
-#include <respondd.h>
-
-#include <json-c/json.h>
-#include <libgluonutil.h>
-
-
-struct json_object * get_site_name(void) {
-	struct json_object *site = gluonutil_load_site_config();
-	if (!site)
-		return NULL;
-
-	struct json_object *ret = NULL;
-	json_object_object_get_ex(site, "site_name", &ret);
-	if (ret)
-		json_object_get(ret);
-
-	json_object_put(site);
-	return ret;
-}
-
-static struct json_object * respondd_provider_nodeinfo(void) {
-	struct json_object *ret = json_object_new_object();
-
-	struct json_object *system = json_object_new_object();
-	json_object_object_add(system, "site_name", get_site_name());
-	json_object_object_add(ret, "system", system);
-
-	return ret;
-}
-
-
-const struct respondd_provider_info respondd_providers[] = {
-	{"nodeinfo", respondd_provider_nodeinfo},
-	{}
-};