Browse Source

First step to rename ffpb-packages to ffho-packages

Michael Schwarz 8 years ago
parent
commit
697224fc11
30 changed files with 89 additions and 176 deletions
  1. 9 9
      ffho/ffho-alfred-config/Makefile
  2. 0 0
      ffho/ffho-alfred-config/files/lib/gluon/announce/nodeinfo.d/system/site_name
  3. 9 9
      ffho/ffho-alfred-watchdog/Makefile
  4. 2 2
      ffho/ffho-alfred-watchdog/files/bin/ffho-alfred-watchdog
  5. 1 0
      ffho/ffho-alfred-watchdog/files/lib/gluon/cron/ffho-alfred-watchdog
  6. 11 11
      ffho/ffho-debug/Makefile
  7. 0 0
      ffho/ffho-debug/files/bin/ffho-debug
  8. 2 2
      ffho/ffho-debug/files/bin/ffho-debug-live
  9. 1 0
      ffho/ffho-debug/files/lib/gluon/cron/ffho-debug
  10. 14 14
      ffho/ffho-ebtables-net-rules/Makefile
  11. 1 0
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/100-ffho-net-chain
  12. 7 0
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv4-space
  13. 4 4
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv6-spaces
  14. 1 0
      ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/400-add-ffho-net-chain
  15. 11 11
      ffho/ffho-node-tuning/Makefile
  16. 0 0
      ffho/ffho-node-tuning/files/lib/gluon/upgrade/180-increase-arp-caches
  17. 10 10
      ffho/ffho-openwrt-migration-tools/Makefile
  18. 0 0
      ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/40-wireless-config-hwmode-fix
  19. 0 0
      ffho/ffho-openwrt-migration-tools/files/lib/netifd/hostapd.sh
  20. 0 0
      ffho/ffho-openwrt-migration-tools/files/lib/netifd/wireless/mac80211.sh
  21. 0 0
      ffho/ffho-openwrt-migration-tools/files/lib/wifi/mac80211.sh
  22. 6 6
      ffho/ffho-wifi-blackout-workaround/Makefile
  23. 0 0
      ffho/ffho-wifi-blackout-workaround/files/etc/hotplug.d/iface/99-ath9k_disable_ani
  24. 0 1
      ffpb/ffpb-alfred-watchdog/files/lib/gluon/cron/ffpb-alfred-watchdog
  25. 0 72
      ffpb/ffpb-banner/Makefile
  26. 0 15
      ffpb/ffpb-banner/files/etc/banner.ffpb
  27. 0 1
      ffpb/ffpb-debug/files/lib/gluon/cron/ffpb-debug
  28. 0 1
      ffpb/ffpb-ebtables-net-rules/files/lib/gluon/ebtables/100-ffpb-net-chain
  29. 0 7
      ffpb/ffpb-ebtables-net-rules/files/lib/gluon/ebtables/110-ffpb-net-allow-ipv4-space
  30. 0 1
      ffpb/ffpb-ebtables-net-rules/files/lib/gluon/ebtables/400-add-ffpb-net-chain

+ 9 - 9
ffpb/ffpb-alfred-config/Makefile → ffho/ffho-alfred-config/Makefile

@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/rules.mk
 
 
-PKG_NAME:=ffpb-alfred-config
+PKG_NAME:=ffho-alfred-config
 PKG_VERSION:=1
 PKG_VERSION:=1
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 
 
@@ -8,17 +8,17 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package.mk
 
 
-define Package/ffpb-alfred-config
-  SECTION:=ffpb
+define Package/ffho-alfred-config
+  SECTION:=ffho
   CATEGORY:=workarounds
   CATEGORY:=workarounds
   TITLE:=Additional A.L.F.R.E.D. config files 
   TITLE:=Additional A.L.F.R.E.D. config files 
   DEPENDS:=+busybox
   DEPENDS:=+busybox
-  MAINTAINER:=Freifunk Paderborn <maschinenraum@paderborn.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffpb-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffpb-packages.git
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 endef
 
 
-define Package/ffpb-alfred-config/description
+define Package/ffho-alfred-config/description
   This package contains additional config files for A.L.F.R.E.D. 
   This package contains additional config files for A.L.F.R.E.D. 
 endef
 endef
 
 
@@ -31,9 +31,9 @@ endef
 define Build/Compile
 define Build/Compile
 endef
 endef
 
 
-define Package/ffpb-alfred-config/install
+define Package/ffho-alfred-config/install
 	$(INSTALL_DIR) $(1)/lib/gluon/announce/nodeinfo.d/system
 	$(INSTALL_DIR) $(1)/lib/gluon/announce/nodeinfo.d/system
 	$(INSTALL_DATA) ./files/lib/gluon/announce/nodeinfo.d/system/* $(1)/lib/gluon/announce/nodeinfo.d/system/
 	$(INSTALL_DATA) ./files/lib/gluon/announce/nodeinfo.d/system/* $(1)/lib/gluon/announce/nodeinfo.d/system/
 endef
 endef
 
 
-$(eval $(call BuildPackage,ffpb-alfred-config))
+$(eval $(call BuildPackage,ffho-alfred-config))

+ 0 - 0
ffpb/ffpb-alfred-config/files/lib/gluon/announce/nodeinfo.d/system/site_name → ffho/ffho-alfred-config/files/lib/gluon/announce/nodeinfo.d/system/site_name


+ 9 - 9
ffpb/ffpb-alfred-watchdog/Makefile → ffho/ffho-alfred-watchdog/Makefile

@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/rules.mk
 
 
-PKG_NAME:=ffpb-alfred-watchdog
+PKG_NAME:=ffho-alfred-watchdog
 PKG_VERSION:=1
 PKG_VERSION:=1
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 
 
@@ -8,17 +8,17 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package.mk
 
 
-define Package/ffpb-alfred-watchdog
-  SECTION:=ffpb
+define Package/ffho-alfred-watchdog
+  SECTION:=ffho
   CATEGORY:=workarounds
   CATEGORY:=workarounds
   TITLE:=A.L.F.R.E.D. crash watchdog
   TITLE:=A.L.F.R.E.D. crash watchdog
   DEPENDS:=+busybox
   DEPENDS:=+busybox
-  MAINTAINER:=Freifunk Paderborn <maschinenraum@paderborn.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffpb-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffpb-packages.git
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 endef
 
 
-define Package/ffpb-alfred-watchdog/description
+define Package/ffho-alfred-watchdog/description
 	Monitors whether or not the A.L.F.R.E.D. is still running on a node or
 	Monitors whether or not the A.L.F.R.E.D. is still running on a node or
 	not. Version 2013.x crashes from time to time and thus some nodes dis-
 	not. Version 2013.x crashes from time to time and thus some nodes dis-
 	appear from the map. It is thus suitable to monitor the state of the
 	appear from the map. It is thus suitable to monitor the state of the
@@ -41,11 +41,11 @@ endef
 define Build/Compile
 define Build/Compile
 endef
 endef
 
 
-define Package/ffpb-alfred-watchdog/install
+define Package/ffho-alfred-watchdog/install
 	$(INSTALL_DIR) $(1)/bin/
 	$(INSTALL_DIR) $(1)/bin/
 	$(INSTALL_DIR) $(1)/lib/gluon/cron/
 	$(INSTALL_DIR) $(1)/lib/gluon/cron/
 	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
 	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
 	$(INSTALL_DATA) ./files/lib/gluon/cron/* $(1)/lib/gluon/cron/
 	$(INSTALL_DATA) ./files/lib/gluon/cron/* $(1)/lib/gluon/cron/
 endef
 endef
 
 
-$(eval $(call BuildPackage,ffpb-alfred-watchdog))
+$(eval $(call BuildPackage,ffho-alfred-watchdog))

+ 2 - 2
ffpb/ffpb-alfred-watchdog/files/bin/ffpb-alfred-watchdog → ffho/ffho-alfred-watchdog/files/bin/ffho-alfred-watchdog

@@ -13,9 +13,9 @@ delay=`expr ${rand} % 55`
 
 
 /usr/sbin/alfred -b bat0 -r 158 > /dev/null 2&>1
 /usr/sbin/alfred -b bat0 -r 158 > /dev/null 2&>1
 if [[ "$?" == 255 ]] ; then
 if [[ "$?" == 255 ]] ; then
-    logger -s -t ffpb-alfred-watchdog -p local0.info "A.L.F.R.E.D. appears to be dead. Triggering a restart now."
+    logger -s -t ffho-alfred-watchdog -p local0.info "A.L.F.R.E.D. appears to be dead. Triggering a restart now."
     /etc/init.d/alfred restart > /dev/null 2&>1
     /etc/init.d/alfred restart > /dev/null 2&>1
-    [[ "$ALFRED_MAJOR_VERSION" -gt 2013 ]] && /bin/ffpb-debug > /dev/null 2&>1
+    [[ "$ALFRED_MAJOR_VERSION" -gt 2013 ]] && /bin/ffho-debug > /dev/null 2&>1
 fi
 fi
 
 
 [[ -e ${LOCK_FILE} ]] && /bin/rm ${LOCK_FILE}
 [[ -e ${LOCK_FILE} ]] && /bin/rm ${LOCK_FILE}

+ 1 - 0
ffho/ffho-alfred-watchdog/files/lib/gluon/cron/ffho-alfred-watchdog

@@ -0,0 +1 @@
+55 * * * * /bin/ffho-alfred-watchdog

+ 11 - 11
ffpb/ffpb-debug/Makefile → ffho/ffho-debug/Makefile

@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/rules.mk
 
 
-PKG_NAME:=ffpb-debug
+PKG_NAME:=ffho-debug
 PKG_VERSION:=1
 PKG_VERSION:=1
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 
 
@@ -8,18 +8,18 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package.mk
 
 
-define Package/ffpb-debug
-  SECTION:=ffpb
+define Package/ffho-debug
+  SECTION:=ffho
   CATEGORY:=debug
   CATEGORY:=debug
-  TITLE:=Debug scripts for Freifunk Paderborn
+  TITLE:=Debug scripts for Freifunk Hochstift
   DEPENDS:=+gluon-core +ubus +libubox +busybox
   DEPENDS:=+gluon-core +ubus +libubox +busybox
-  MAINTAINER:=Freifunk Paderborn <maschinenraum@paderborn.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffpb-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffpb-packages.git
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 endef
 
 
-define Package/ffpb-debug/description
-	Debug scripts for FFPB
+define Package/ffho-debug/description
+	Debug scripts for FFHO
 endef
 endef
 
 
 define Build/Prepare
 define Build/Prepare
@@ -32,11 +32,11 @@ endef
 define Build/Compile
 define Build/Compile
 endef
 endef
 
 
-define Package/ffpb-debug/install
+define Package/ffho-debug/install
 	$(INSTALL_DIR) $(1)/bin/
 	$(INSTALL_DIR) $(1)/bin/
 	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
 	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
 	$(INSTALL_DIR) $(1)/lib/gluon/cron/
 	$(INSTALL_DIR) $(1)/lib/gluon/cron/
 	$(INSTALL_DATA) ./files/lib/gluon/cron/* $(1)/lib/gluon/cron/
 	$(INSTALL_DATA) ./files/lib/gluon/cron/* $(1)/lib/gluon/cron/
 endef
 endef
 
 
-$(eval $(call BuildPackage,ffpb-debug))
+$(eval $(call BuildPackage,ffho-debug))

+ 0 - 0
ffpb/ffpb-debug/files/bin/ffpb-debug → ffho/ffho-debug/files/bin/ffho-debug


+ 2 - 2
ffpb/ffpb-debug/files/bin/ffpb-debug-live → ffho/ffho-debug/files/bin/ffho-debug-live

@@ -1,9 +1,9 @@
 #!/bin/sh
 #!/bin/sh
 
 
-TEMP_DATA_FILE="/tmp/ffpb-live-debug.dat"
+TEMP_DATA_FILE="/tmp/ffho-live-debug.dat"
 LIVE_DEBUG_TARGET_HOST="fdca:ffee:ff12:a254::da7a"
 LIVE_DEBUG_TARGET_HOST="fdca:ffee:ff12:a254::da7a"
 LIVE_DEBUG_TARGET_HOST_PORT=1338
 LIVE_DEBUG_TARGET_HOST_PORT=1338
-LIVE_DEBUG_GRAPHITE_DATAPATH_BASE="ffpb.debug."$(lua -e 'print(require("gluon.sysconfig").primary_mac)')
+LIVE_DEBUG_GRAPHITE_DATAPATH_BASE="ffho.debug."$(lua -e 'print(require("gluon.sysconfig").primary_mac)')
 
 
 . /etc/openwrt_release
 . /etc/openwrt_release
 . /usr/share/libubox/jshn.sh
 . /usr/share/libubox/jshn.sh

+ 1 - 0
ffho/ffho-debug/files/lib/gluon/cron/ffho-debug

@@ -0,0 +1 @@
+*/15 * * * * /bin/ffho-send-stored-debug

+ 14 - 14
ffpb/ffpb-ebtables-net-rules/Makefile → ffho/ffho-ebtables-net-rules/Makefile

@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/rules.mk
 
 
-PKG_NAME:=ffpb-ebtables-net-rules
+PKG_NAME:=ffho-ebtables-net-rules
 PKG_VERSION:=1
 PKG_VERSION:=1
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 
 
@@ -8,17 +8,17 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package.mk
 
 
-define Package/ffpb-ebtables-net-rules
-  SECTION:=ffpb
+define Package/ffho-ebtables-net-rules
+  SECTION:=ffho
   CATEGORY:=Gluon
   CATEGORY:=Gluon
-  TITLE:=FFPB net-specific ebtables rules to filter unreasonable L2 traffic.
+  TITLE:=FFHO net-specific ebtables rules to filter unreasonable L2 traffic.
   DEPENDS:=+gluon-core +gluon-ebtables
   DEPENDS:=+gluon-core +gluon-ebtables
-  MAINTAINER:=Freifunk Paderborn <maschinenraum@paderborn.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffpb-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffpb-packages.git
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 endef
 
 
-define Package/ffpb-ebtables-net-rules/description
+define Package/ffho-ebtables-net-rules/description
 	This package adds an additional layer-2 filter-ruleset to prevent traffic,
 	This package adds an additional layer-2 filter-ruleset to prevent traffic,
 	which is not destined for any Freifunk Paderborn layer-3 specific target,
 	which is not destined for any Freifunk Paderborn layer-3 specific target,
 	from entering the network via the nodes.
 	from entering the network via the nodes.
@@ -34,12 +34,12 @@ endef
 define Build/Compile
 define Build/Compile
 endef
 endef
 
 
-define Package/ffpb-ebtables-net-rules/install
+define Package/ffho-ebtables-net-rules/install
 	$(INSTALL_DIR) $(1)/lib/gluon/ebtables/
 	$(INSTALL_DIR) $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/100-ffpb-net-chain $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/110-ffpb-net-allow-ipv4-space $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/110-ffpb-net-allow-ipv6-spaces $(1)/lib/gluon/ebtables/
-	$(CP) ./files/lib/gluon/ebtables/400-add-ffpb-net-chain $(1)/lib/gluon/ebtables/
+	$(CP) ./files/lib/gluon/ebtables/100-ffho-net-chain $(1)/lib/gluon/ebtables/
+	$(CP) ./files/lib/gluon/ebtables/110-ffho-net-allow-ipv4-space $(1)/lib/gluon/ebtables/
+	$(CP) ./files/lib/gluon/ebtables/110-ffho-net-allow-ipv6-spaces $(1)/lib/gluon/ebtables/
+	$(CP) ./files/lib/gluon/ebtables/400-add-ffho-net-chain $(1)/lib/gluon/ebtables/
 endef
 endef
 
 
-$(eval $(call BuildPackage,ffpb-ebtables-net-rules))
+$(eval $(call BuildPackage,ffho-ebtables-net-rules))

+ 1 - 0
ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/100-ffho-net-chain

@@ -0,0 +1 @@
+chain('FFHO_NET_ONLY', 'DROP') 

+ 7 - 0
ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv4-space

@@ -0,0 +1,7 @@
+siteConfig = require("gluon.site_config")
+prefix4 = siteConfig.prefix4
+
+rule ('FFHO_NET_ONLY -p IPv4 --ip-protocol udp --ip-destination-port 67 -j RETURN')
+rule ('FFHO_NET_ONLY -p IPv4 --ip-src ' .. prefix4 .. ' -j RETURN')
+rule ('FFHO_NET_ONLY -p ARP --arp-ip-src ' .. prefix4 .. ' --arp-ip-dst ' .. prefix4 .. ' -j RETURN')
+rule ('FFHO_NET_ONLY -p ARP --arp-ip-src 0.0.0.0/0 --arp-ip-dst ' .. prefix4 .. ' -j RETURN')

+ 4 - 4
ffpb/ffpb-ebtables-net-rules/files/lib/gluon/ebtables/110-ffpb-net-allow-ipv6-spaces → ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/110-ffho-net-allow-ipv6-spaces

@@ -10,10 +10,10 @@ function list_iter (_table)
     end 
     end 
 end
 end
 
 
-rule ('FFPB_NET_ONLY -p IPv6 --ip6-src fe80::/10 -j RETURN')
-rule ('FFPB_NET_ONLY -p IPv6 --ip6-dst ff00::/8 -j RETURN')
-rule ('FFPB_NET_ONLY -p IPv6 --ip6-src ' .. siteConfig.prefix6 .. ' -j RETURN')
+rule ('FFHO_NET_ONLY -p IPv6 --ip6-src fe80::/10 -j RETURN')
+rule ('FFHO_NET_ONLY -p IPv6 --ip6-dst ff00::/8 -j RETURN')
+rule ('FFHO_NET_ONLY -p IPv6 --ip6-src ' .. siteConfig.prefix6 .. ' -j RETURN')
 
 
 for prefix in list_iter(siteConfig.additional_prefix6) do
 for prefix in list_iter(siteConfig.additional_prefix6) do
-	rule ('FFPB_NET_ONLY -p IPv6 --ip6-src ' .. prefix .. ' -j RETURN')
+	rule ('FFHO_NET_ONLY -p IPv6 --ip6-src ' .. prefix .. ' -j RETURN')
 end
 end

+ 1 - 0
ffho/ffho-ebtables-net-rules/files/lib/gluon/ebtables/400-add-ffho-net-chain

@@ -0,0 +1 @@
+rule 'FORWARD --logical-in br-client -i ! bat0 -j FFHO_NET_ONLY'

+ 11 - 11
ffpb/ffpb-node-tuning/Makefile → ffho/ffho-node-tuning/Makefile

@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/rules.mk
 
 
-PKG_NAME:=ffpb-node-tuning
+PKG_NAME:=ffho-node-tuning
 PKG_VERSION:=1
 PKG_VERSION:=1
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 
 
@@ -8,17 +8,17 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package.mk
 
 
-define Package/ffpb-node-tuning
-  SECTION:=ffpb
+define Package/ffho-node-tuning
+  SECTION:=ffho
   CATEGORY:=Gluon
   CATEGORY:=Gluon
-  TITLE:=Freifunk Paderborn Node Tuning-Settings
+  TITLE:=Freifunk Hochstift Node Tuning-Settings
   DEPENDS:=+gluon-core +busybox
   DEPENDS:=+gluon-core +busybox
-  MAINTAINER:=Freifunk Paderborn <maschinenraum@paderborn.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffpb-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffpb-packages.git
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 endef
 
 
-define Package/ffpb-node-tuning/description
+define Package/ffho-node-tuning/description
 	As its name states, this packages applies some config optimizations (like
 	As its name states, this packages applies some config optimizations (like
 	tweaking kernal knobs via sysctl) on the nodes.
 	tweaking kernal knobs via sysctl) on the nodes.
 	For the most knobs Gluon sticks for OpenWRT defaults for good reasons, as
 	For the most knobs Gluon sticks for OpenWRT defaults for good reasons, as
@@ -38,12 +38,12 @@ endef
 define Build/Compile
 define Build/Compile
 endef
 endef
 
 
-define Package/ffpb-node-tuning/postinst
+define Package/ffho-node-tuning/postinst
 endef
 endef
 
 
-define Package/ffpb-node-tuning/install
+define Package/ffho-node-tuning/install
 	$(INSTALL_DIR) $(1)/lib/gluon/upgrade/
 	$(INSTALL_DIR) $(1)/lib/gluon/upgrade/
 	$(INSTALL_BIN) ./files//lib/gluon/upgrade/* $(1)/lib/gluon/upgrade/
 	$(INSTALL_BIN) ./files//lib/gluon/upgrade/* $(1)/lib/gluon/upgrade/
 endef
 endef
 
 
-$(eval $(call BuildPackage,ffpb-node-tuning))
+$(eval $(call BuildPackage,ffho-node-tuning))

+ 0 - 0
ffpb/ffpb-node-tuning/files/lib/gluon/upgrade/180-increase-arp-caches → ffho/ffho-node-tuning/files/lib/gluon/upgrade/180-increase-arp-caches


+ 10 - 10
ffpb/ffpb-openwrt-migration-tools/Makefile → ffho/ffho-openwrt-migration-tools/Makefile

@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/rules.mk
 
 
-PKG_NAME:=ffpb-openwrt-migration-tools
+PKG_NAME:=ffho-openwrt-migration-tools
 PKG_VERSION:=1
 PKG_VERSION:=1
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 
 
@@ -8,17 +8,17 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package.mk
 
 
-define Package/ffpb-openwrt-migration-tools
-  SECTION:=ffpb
+define Package/ffho-openwrt-migration-tools
+  SECTION:=ffho
   CATEGORY:=Gluon
   CATEGORY:=Gluon
   TITLE:=Toolset of scripts that support the migration from one version of OpenWRT to another.
   TITLE:=Toolset of scripts that support the migration from one version of OpenWRT to another.
   DEPENDS:=+gluon-core +busybox +hostapd-common +netifd
   DEPENDS:=+gluon-core +busybox +hostapd-common +netifd
-  MAINTAINER:=Freifunk Paderborn <maschinenraum@paderborn.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffpb-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffpb-packages.git
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
 endef
 endef
 
 
-define Package/ffpb-openwrt-migration-tools/description
+define Package/ffho-openwrt-migration-tools/description
 	A collection of scripts that fix and cleanup configurations on a node
 	A collection of scripts that fix and cleanup configurations on a node
 	when migrating the Gluon base-version of OpenWRT from one major release
 	when migrating the Gluon base-version of OpenWRT from one major release
 	to another.
 	to another.
@@ -34,7 +34,7 @@ endef
 define Build/Compile
 define Build/Compile
 endef
 endef
 
 
-define Package/ffpb-openwrt-migration-tools/preinst
+define Package/ffho-openwrt-migration-tools/preinst
 #!/bin/sh
 #!/bin/sh
 cd "$${IPKG_INSTROOT}/lib/netifd/wireless/"
 cd "$${IPKG_INSTROOT}/lib/netifd/wireless/"
 if [ -f "mac80211.sh" ] ; then
 if [ -f "mac80211.sh" ] ; then
@@ -51,7 +51,7 @@ fi
 exit 0
 exit 0
 endef
 endef
 
 
-define Package/ffpb-openwrt-migration-tools/install
+define Package/ffho-openwrt-migration-tools/install
 	$(INSTALL_DIR) $(1)/etc/uci-defaults/
 	$(INSTALL_DIR) $(1)/etc/uci-defaults/
 	$(INSTALL_DIR) $(1)/lib/netifd/wireless/
 	$(INSTALL_DIR) $(1)/lib/netifd/wireless/
 	$(INSTALL_DIR) $(1)/lib/wifi/
 	$(INSTALL_DIR) $(1)/lib/wifi/
@@ -61,4 +61,4 @@ define Package/ffpb-openwrt-migration-tools/install
 	$(CP) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi/
 	$(CP) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi/
 endef
 endef
 
 
-$(eval $(call BuildPackage,ffpb-openwrt-migration-tools))
+$(eval $(call BuildPackage,ffho-openwrt-migration-tools))

+ 0 - 0
ffpb/ffpb-openwrt-migration-tools/files/etc/uci-defaults/40-wireless-config-hwmode-fix → ffho/ffho-openwrt-migration-tools/files/etc/uci-defaults/40-wireless-config-hwmode-fix


+ 0 - 0
ffpb/ffpb-openwrt-migration-tools/files/lib/netifd/hostapd.sh → ffho/ffho-openwrt-migration-tools/files/lib/netifd/hostapd.sh


+ 0 - 0
ffpb/ffpb-openwrt-migration-tools/files/lib/netifd/wireless/mac80211.sh → ffho/ffho-openwrt-migration-tools/files/lib/netifd/wireless/mac80211.sh


+ 0 - 0
ffpb/ffpb-openwrt-migration-tools/files/lib/wifi/mac80211.sh → ffho/ffho-openwrt-migration-tools/files/lib/wifi/mac80211.sh


+ 6 - 6
ffpb/ffpb-wifi-blackout-workaround/Makefile → ffho/ffho-wifi-blackout-workaround/Makefile

@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/rules.mk
 
 
-PKG_NAME:=ffpb-wifi-blackout-workaround
+PKG_NAME:=ffho-wifi-blackout-workaround
 PKG_VERSION:=1
 PKG_VERSION:=1
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
 
 
@@ -8,14 +8,14 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package.mk
 
 
-define Package/ffpb-wifi-blackout-workaround
-  SECTION:=ffpb
+define Package/ffho-wifi-blackout-workaround
+  SECTION:=ffho
   CATEGORY:=workarounds
   CATEGORY:=workarounds
   TITLE:=WiFi-Blackout workaround
   TITLE:=WiFi-Blackout workaround
   DEPENDS:=+busybox
   DEPENDS:=+busybox
 endef
 endef
 
 
-define Package/ffpb-wifi-blackout-workaround/description
+define Package/ffho-wifi-blackout-workaround/description
 	Disables ANI when the "stable" firmware branch is used.
 	Disables ANI when the "stable" firmware branch is used.
 endef
 endef
 
 
@@ -29,8 +29,8 @@ endef
 define Build/Compile
 define Build/Compile
 endef
 endef
 
 
-define Package/ffpb-wifi-blackout-workaround/install
+define Package/ffho-wifi-blackout-workaround/install
 	$(CP) ./files/* $(1)/
 	$(CP) ./files/* $(1)/
 endef
 endef
 
 
-$(eval $(call BuildPackage,ffpb-wifi-blackout-workaround))
+$(eval $(call BuildPackage,ffho-wifi-blackout-workaround))

+ 0 - 0
ffpb/ffpb-wifi-blackout-workaround/files/etc/hotplug.d/iface/99-ath9k_disable_ani → ffho/ffho-wifi-blackout-workaround/files/etc/hotplug.d/iface/99-ath9k_disable_ani


+ 0 - 1
ffpb/ffpb-alfred-watchdog/files/lib/gluon/cron/ffpb-alfred-watchdog

@@ -1 +0,0 @@
-55 * * * * /bin/ffpb-alfred-watchdog

+ 0 - 72
ffpb/ffpb-banner/Makefile

@@ -1,72 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ffpb-banner
-PKG_VERSION:=1
-PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ffpb-banner
-  SECTION:=ffpb
-  CATEGORY:=Customization
-  TITLE:=Banner file replacement
-  DEPENDS:=+gluon-core +busybox
-  MAINTAINER:=Freifunk Paderborn <maschinenraum@paderborn.freifunk.net>
-  URL:=https://git.c3pb.de/freifunk-pb/ffpb-packages
-  SOURCE:=git@git.c3pb.de:freifunk-pb/ffpb-packages.git
-endef
-
-define Package/ffpb-banner/description
-	Banner file replacement
-endef
-
-define Build/Prepare
-	mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/ffpb-banner/preinst
-#!/bin/sh
-cd "$${IPKG_INSTROOT}/etc/"
-if [ -h "./banner" ] ; then
-	/bin/rm "./banner"
-elif [ -f "./banner" ] ; then
-	/bin/mv "./banner" "./banner.openwrt"
-fi
-/bin/ln -s "./banner.openwrt" "./banner"
-exit 0
-endef
-
-define Package/ffpb-banner/postinst
-#!/bin/sh
-cd "$${IPKG_INSTROOT}/etc/"
-[ -h "./banner" ] && /bin/rm -f "./banner"
-/bin/ln -s "./banner.ffpb" "./banner"
-exit $$?
-endef
-
-define Package/ffpb-banner/prerm
-#!/bin/sh
-cd "$${IPKG_INSTROOT}/etc/"
-if [ -h "./banner" ] ; then
-	[[ "$$(readlink -n ./banner)" == "./banner.ffpb" ]] && \
-	/bin/rm -f "./banner" && \
-	[ -f "./banner.openwrt" ] && \
-	/bin/ln -s "./banner.openwrt" "./banner"
-fi
-exit 0
-endef
-
-define Package/ffpb-banner/install
-	$(INSTALL_DIR) $(1)/etc/
-	$(INSTALL_DATA) ./files/etc/banner.ffpb $(1)/etc/
-endef
-
-$(eval $(call BuildPackage,ffpb-banner))

+ 0 - 15
ffpb/ffpb-banner/files/etc/banner.ffpb

@@ -1,15 +0,0 @@
-   _____         _ ___         _      _____       _         _
-  |   __|___ ___|_|  _|_ _ ___| |_   |  _  |___ _| |___ ___| |_ ___ ___ ___
-  |   __|  _| -_| |  _| | |   | '_|  |   __| .'| . | -_|  _| . | . |  _|   |
-  |__|  |_| |___|_|_| |___|_|_|_,_|  |__|  |__,|___|___|_| |___|___|_| |_|_|
-
-  ---        "Du bist hier Root - mach bloß keinen Scheiß!" (tm)         ---
-
-  Web    : http://paderborn.freifunk.net/
-  Kontakt: kontakt@paderborn.freifunk.net und  (EMail)
-           https://youngage.eu/chat/?#ffpb     (Chat)
-
-  Deine FFPB-Werkzeuge:
-  - ffpb-debug        (Debug-Report für Unterstützung senden)
-  - autoupdater -f    (Firmware-Update erzwingen) 
-

+ 0 - 1
ffpb/ffpb-debug/files/lib/gluon/cron/ffpb-debug

@@ -1 +0,0 @@
-*/15 * * * * /bin/ffpb-send-stored-debug

+ 0 - 1
ffpb/ffpb-ebtables-net-rules/files/lib/gluon/ebtables/100-ffpb-net-chain

@@ -1 +0,0 @@
-chain('FFPB_NET_ONLY', 'DROP') 

+ 0 - 7
ffpb/ffpb-ebtables-net-rules/files/lib/gluon/ebtables/110-ffpb-net-allow-ipv4-space

@@ -1,7 +0,0 @@
-siteConfig = require("gluon.site_config")
-prefix4 = siteConfig.prefix4
-
-rule ('FFPB_NET_ONLY -p IPv4 --ip-protocol udp --ip-destination-port 67 -j RETURN')
-rule ('FFPB_NET_ONLY -p IPv4 --ip-src ' .. prefix4 .. ' -j RETURN')
-rule ('FFPB_NET_ONLY -p ARP --arp-ip-src ' .. prefix4 .. ' --arp-ip-dst ' .. prefix4 .. ' -j RETURN')
-rule ('FFPB_NET_ONLY -p ARP --arp-ip-src 0.0.0.0/0 --arp-ip-dst ' .. prefix4 .. ' -j RETURN')

+ 0 - 1
ffpb/ffpb-ebtables-net-rules/files/lib/gluon/ebtables/400-add-ffpb-net-chain

@@ -1 +0,0 @@
-rule 'FORWARD --logical-in br-client -i ! bat0 -j FFPB_NET_ONLY'