Browse Source

Minify all Lua code

Karsten Böddeker 7 years ago
parent
commit
3f8381d864
39 changed files with 52 additions and 25 deletions
  1. 4 2
      ffho/ffho-ap-timer/Makefile
  2. 3 3
      ffho/ffho-ap-timer/luasrc/usr/sbin/ap-timer
  3. 3 1
      ffho/ffho-ath9k-blackout-workaround/Makefile
  4. 0 0
      ffho/ffho-ath9k-blackout-workaround/luasrc/lib/gluon/upgrade/900-ath9k-blackout-workaround
  5. 0 0
      ffho/ffho-ath9k-blackout-workaround/luasrc/usr/sbin/ath9k-blackout-workaround
  6. 3 2
      ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile
  7. 0 0
      ffho/ffho-autoupdater-wifi-fallback-legacy/luasrc/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy
  8. 6 0
      ffho/ffho-autoupdater-wifi-fallback/Makefile
  9. 0 0
      ffho/ffho-autoupdater-wifi-fallback/luasrc/lib/gluon/upgrade/510-autoupdater-wifi-fallback
  10. 0 0
      ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/lib/lua/autoupdater-wifi-fallback/util.lua
  11. 0 0
      ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/autoupdater-wifi-fallback
  12. 0 0
      ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/wpa_supplicant
  13. 6 0
      ffho/ffho-autoupdater/Makefile
  14. 0 0
      ffho/ffho-autoupdater/luasrc/lib/gluon/upgrade/500-autoupdater
  15. 3 2
      ffho/ffho-config-mode-site-select/Makefile
  16. 0 0
      ffho/ffho-config-mode-site-select/luasrc/lib/gluon/config-mode/wizard/0200-site-select.lua
  17. 3 3
      ffho/ffho-debug/Makefile
  18. 0 0
      ffho/ffho-debug/luasrc/bin/ffho-debug
  19. 3 2
      ffho/ffho-geo-location-altitude-delete/Makefile
  20. 0 0
      ffho/ffho-geo-location-altitude-delete/luasrc/lib/gluon/upgrade/900-geo-location-altitude-delete
  21. 2 1
      ffho/ffho-luci-autoupdater-wifi-fallback/Makefile
  22. 0 0
      ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/controller/admin/autoupdater.lua
  23. 0 0
      ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/model/cbi/admin/autoupdater.lua
  24. 2 1
      ffho/ffho-luci-remote-syslog/Makefile
  25. 0 0
      ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/controller/admin/remote-syslog.lua
  26. 0 0
      ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua
  27. 3 3
      ffho/ffho-node-tuning/Makefile
  28. 0 0
      ffho/ffho-node-tuning/luasrc/lib/gluon/upgrade/180-increase-arp-caches
  29. 3 2
      ffho/ffho-site-auto-select/Makefile
  30. 0 0
      ffho/ffho-site-auto-select/luasrc/lib/gluon/upgrade/003-site-auto-select
  31. 0 0
      ffho/ffho-site-auto-select/luasrc/usr/lib/lua/gluon/pointwithinshape.lua
  32. 0 0
      ffho/ffho-site-auto-select/luasrc/usr/sbin/ffho-site-auto-select
  33. 3 1
      ffho/ffho-site-generate/Makefile
  34. 0 0
      ffho/ffho-site-generate/luasrc/lib/gluon/upgrade/005-set-site-config
  35. 0 0
      ffho/ffho-site-generate/luasrc/usr/lib/lua/gluon/site_generate.lua
  36. 3 1
      ffho/ffho-status-page/Makefile
  37. 0 0
      ffho/ffho-status-page/luasrc/lib/gluon/status-page/www/cgi-bin/status
  38. 2 1
      ffho/ffho-txpower-fix/Makefile
  39. 0 0
      ffho/ffho-txpower-fix/luasrc/lib/gluon/upgrade/210-ffho-txpower-fix

+ 4 - 2
ffho/ffho-ap-timer/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-ap-timer
   SECTION:=ffho
@@ -29,10 +29,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-ap-timer/install
-  $(CP) ./files/* $(1)/
+	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-ap-timer))

+ 3 - 3
ffho/ffho-ap-timer/files/usr/sbin/ap-timer → ffho/ffho-ap-timer/luasrc/usr/sbin/ap-timer

@@ -2,7 +2,7 @@
 local timestamp = os.time()
 local uci = require('luci.model.uci').cursor()
 
-function compare(list, value)
+local function compare(list, value)
   if not list then
     return nil
   end
@@ -16,7 +16,7 @@ function compare(list, value)
   return false
 end
 
-function getDay()
+local function getDay()
   local type = uci:get('ap-timer','settings','type')
   if type == 'day' then return 'all'
   elseif type == 'week' then return os.date('%a', timestamp)
@@ -25,7 +25,7 @@ function getDay()
   end
 end
 
-function apSet(value)
+local function apSet(value)
   local execWifi = false
   local radios = {'client_radio0', 'client_radio1'}
   for _, radio in ipairs(radios) do

+ 3 - 1
ffho/ffho-ath9k-blackout-workaround/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-ath9k-blackout-workaround
   SECTION:=ffho
@@ -29,10 +29,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-ath9k-blackout-workaround/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 define Package/ffho-ath9k-blackout-workaround/postinst

+ 0 - 0
ffho/ffho-ath9k-blackout-workaround/files/lib/gluon/upgrade/900-ath9k-blackout-workaround → ffho/ffho-ath9k-blackout-workaround/luasrc/lib/gluon/upgrade/900-ath9k-blackout-workaround


+ 0 - 0
ffho/ffho-ath9k-blackout-workaround/files/usr/sbin/ath9k-blackout-workaround → ffho/ffho-ath9k-blackout-workaround/luasrc/usr/sbin/ath9k-blackout-workaround


+ 3 - 2
ffho/ffho-autoupdater-wifi-fallback-legacy/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-autoupdater-wifi-fallback-legacy
   SECTION:=ffho
@@ -30,10 +30,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-autoupdater-wifi-fallback-legacy/install
-  $(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-autoupdater-wifi-fallback-legacy))

+ 0 - 0
ffho/ffho-autoupdater-wifi-fallback-legacy/files/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy → ffho/ffho-autoupdater-wifi-fallback-legacy/luasrc/lib/gluon/upgrade/505-autoupdater-wifi-fallback-legacy


+ 6 - 0
ffho/ffho-autoupdater-wifi-fallback/Makefile

@@ -23,8 +23,14 @@ define Build/Prepare
 	$(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+define Build/Compile
+	$(call Build/Compile/Default)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
+endef
+
 define Package/ffho-autoupdater-wifi-fallback/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 
 	$(INSTALL_DIR) $(1)/lib/gluon/respondd
 	$(CP) $(PKG_BUILD_DIR)/respondd.so $(1)/lib/gluon/respondd/autoupdater-wifi-fallback.so

+ 0 - 0
ffho/ffho-autoupdater-wifi-fallback/files/lib/gluon/upgrade/510-autoupdater-wifi-fallback → ffho/ffho-autoupdater-wifi-fallback/luasrc/lib/gluon/upgrade/510-autoupdater-wifi-fallback


+ 0 - 0
ffho/ffho-autoupdater-wifi-fallback/files/usr/lib/lua/autoupdater-wifi-fallback/util.lua → ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/lib/lua/autoupdater-wifi-fallback/util.lua


+ 0 - 0
ffho/ffho-autoupdater-wifi-fallback/files/usr/sbin/autoupdater-wifi-fallback → ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/autoupdater-wifi-fallback


+ 0 - 0
ffho/ffho-autoupdater-wifi-fallback/files/usr/sbin/wpa_supplicant → ffho/ffho-autoupdater-wifi-fallback/luasrc/usr/sbin/wpa_supplicant


+ 6 - 0
ffho/ffho-autoupdater/Makefile

@@ -24,8 +24,14 @@ define Build/Prepare
 	$(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+define Build/Compile
+	$(call Build/Compile/Default)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
+endef
+
 define Package/ffho-autoupdater/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 
 	$(INSTALL_DIR) $(1)/lib/gluon/respondd
 	$(CP) $(PKG_BUILD_DIR)/respondd.so $(1)/lib/gluon/respondd/autoupdater.so

+ 0 - 0
ffho/ffho-autoupdater/files/lib/gluon/upgrade/500-autoupdater → ffho/ffho-autoupdater/luasrc/lib/gluon/upgrade/500-autoupdater


+ 3 - 2
ffho/ffho-config-mode-site-select/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=1
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 PKG_CONFIG_DEPENDS += $(GLUON_I18N_CONFIG)
 
@@ -28,10 +28,11 @@ endef
 
 define Build/Compile
 	$(call GluonBuildI18N,ffho-config-mode-site-select,i18n)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-config-mode-site-select/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(call GluonInstallI18N,ffho-config-mode-site-select,$(1))
 endef
 

+ 0 - 0
ffho/ffho-config-mode-site-select/files/lib/gluon/config-mode/wizard/0200-site-select.lua → ffho/ffho-config-mode-site-select/luasrc/lib/gluon/config-mode/wizard/0200-site-select.lua


+ 3 - 3
ffho/ffho-debug/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-debug
   SECTION:=ffho
@@ -29,11 +29,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-debug/install
-	$(INSTALL_DIR) $(1)/bin/
-	$(INSTALL_BIN) ./files/bin/* $(1)/bin/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-debug))

+ 0 - 0
ffho/ffho-debug/files/bin/ffho-debug → ffho/ffho-debug/luasrc/bin/ffho-debug


+ 3 - 2
ffho/ffho-geo-location-altitude-delete/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-geo-location-altitude-delete
   SECTION:=ffho
@@ -28,10 +28,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-geo-location-altitude-delete/install
-  $(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-geo-location-altitude-delete))

+ 0 - 0
ffho/ffho-geo-location-altitude-delete/files/lib/gluon/upgrade/900-geo-location-altitude-delete → ffho/ffho-geo-location-altitude-delete/luasrc/lib/gluon/upgrade/900-geo-location-altitude-delete


+ 2 - 1
ffho/ffho-luci-autoupdater-wifi-fallback/Makefile

@@ -29,10 +29,11 @@ endef
 
 define Build/Compile
 	$(call GluonBuildI18N,ffho-luci-autoupdater-wifi-fallback,i18n)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-luci-autoupdater-wifi-fallback/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(call GluonInstallI18N,ffho-luci-autoupdater-wifi-fallback,$(1))
 endef
 

+ 0 - 0
ffho/ffho-luci-autoupdater-wifi-fallback/files/usr/lib/lua/luci/controller/admin/autoupdater.lua → ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/controller/admin/autoupdater.lua


+ 0 - 0
ffho/ffho-luci-autoupdater-wifi-fallback/files/usr/lib/lua/luci/model/cbi/admin/autoupdater.lua → ffho/ffho-luci-autoupdater-wifi-fallback/luasrc/usr/lib/lua/luci/model/cbi/admin/autoupdater.lua


+ 2 - 1
ffho/ffho-luci-remote-syslog/Makefile

@@ -28,10 +28,11 @@ endef
 
 define Build/Compile
 	$(call GluonBuildI18N,ffho-luci-remote-syslog,i18n)
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-luci-remote-syslog/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(call GluonInstallI18N,ffho-luci-remote-syslog,$(1))
 endef
 

+ 0 - 0
ffho/ffho-luci-remote-syslog/files/usr/lib/lua/luci/controller/admin/remote-syslog.lua → ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/controller/admin/remote-syslog.lua


+ 0 - 0
ffho/ffho-luci-remote-syslog/files/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua → ffho/ffho-luci-remote-syslog/luasrc/usr/lib/lua/luci/model/cbi/admin/remote-syslog.lua


+ 3 - 3
ffho/ffho-node-tuning/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-node-tuning
   SECTION:=ffho
@@ -35,11 +35,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-node-tuning/install
-	$(INSTALL_DIR) $(1)/lib/gluon/upgrade/
-	$(INSTALL_BIN) ./files//lib/gluon/upgrade/* $(1)/lib/gluon/upgrade/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-node-tuning))

+ 0 - 0
ffho/ffho-node-tuning/files/lib/gluon/upgrade/180-increase-arp-caches → ffho/ffho-node-tuning/luasrc/lib/gluon/upgrade/180-increase-arp-caches


+ 3 - 2
ffho/ffho-site-auto-select/Makefile

@@ -8,7 +8,7 @@ PFG_BUILD_DEPENDS := lua-cjson/host
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-site-auto-select
   SECTION:=ffho
@@ -31,10 +31,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-site-auto-select/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	$(INSTALL_DIR) $(1)/lib/gluon/site-select
 	lua -e 'print(require("cjson").encode(require("cjson").decode(io.open("$(GLUON_SITEDIR)/extra/geo.json"):read("*a"))))' > $(1)/lib/gluon/site-select/geo.json
 endef

+ 0 - 0
ffho/ffho-site-auto-select/files/lib/gluon/upgrade/003-site-auto-select → ffho/ffho-site-auto-select/luasrc/lib/gluon/upgrade/003-site-auto-select


+ 0 - 0
ffho/ffho-site-auto-select/files/usr/lib/lua/gluon/pointwithinshape.lua → ffho/ffho-site-auto-select/luasrc/usr/lib/lua/gluon/pointwithinshape.lua


+ 0 - 0
ffho/ffho-site-auto-select/files/usr/sbin/ffho-site-auto-select → ffho/ffho-site-auto-select/luasrc/usr/sbin/ffho-site-auto-select


+ 3 - 1
ffho/ffho-site-generate/Makefile

@@ -8,7 +8,7 @@ PFG_BUILD_DEPENDS := lua-cjson/host
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-site-generate
   SECTION:=ffho
@@ -30,10 +30,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-site-generate/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 	lua -e 'print(require("cjson").encode(assert(dofile("$(GLUONDIR)/scripts/site_config.lua"))))' > $(1)/lib/gluon/site-select/default.json
 	lua -e 'print(require("cjson").encode(assert(dofile("./scripts/sites.lua"))))' >  $(1)/lib/gluon/site-select/sites.json
 	if [ -e $(GLUON_SITEDIR)/extra/groups.conf  ]; then lua -e 'print(require("cjson").encode(assert(dofile("./scripts/groupes.lua"))))' >  $(1)/lib/gluon/site-select/groups.json; fi

+ 0 - 0
ffho/ffho-site-generate/files/lib/gluon/upgrade/005-set-site-config → ffho/ffho-site-generate/luasrc/lib/gluon/upgrade/005-set-site-config


+ 0 - 0
ffho/ffho-site-generate/files/usr/lib/lua/gluon/site_generate.lua → ffho/ffho-site-generate/luasrc/usr/lib/lua/gluon/site_generate.lua


+ 3 - 1
ffho/ffho-status-page/Makefile

@@ -6,7 +6,7 @@ PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+include $(GLUONDIR)/include/package.mk
 
 define Package/ffho-status-page
   SECTION:=ffho
@@ -31,10 +31,12 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-status-page/install
 	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-status-page))

+ 0 - 0
ffho/ffho-status-page/files/lib/gluon/status-page/www/cgi-bin/status → ffho/ffho-status-page/luasrc/lib/gluon/status-page/www/cgi-bin/status


+ 2 - 1
ffho/ffho-txpower-fix/Makefile

@@ -33,10 +33,11 @@ define Build/Configure
 endef
 
 define Build/Compile
+	$(call GluonSrcDiet,./luasrc,$(PKG_BUILD_DIR)/luadest/)
 endef
 
 define Package/ffho-txpower-fix/install
-	$(CP) ./files/* $(1)/
+	$(CP) $(PKG_BUILD_DIR)/luadest/* $(1)/
 endef
 
 $(eval $(call BuildPackage,ffho-txpower-fix))

+ 0 - 0
ffho/ffho-txpower-fix/files/lib/gluon/upgrade/210-ffho-txpower-fix → ffho/ffho-txpower-fix/luasrc/lib/gluon/upgrade/210-ffho-txpower-fix