Procházet zdrojové kódy

Update ffho-config-mode-mesh-vpn

Apply Upstream Changes from gluon-config-mode-mesh-vpn
Karsten Böddeker před 8 roky
rodič
revize
3d9db43ff2

+ 2 - 2
ffho/ffho-config-mode-mesh-vpn/Makefile

@@ -14,7 +14,7 @@ define Package/ffho-config-mode-mesh-vpn
   SECTION:=gluon
   CATEGORY:=Gluon
   TITLE:=Toggle mesh-vpn and bandwidth limit
-  DEPENDS:=gluon-config-mode-core-virtual +gluon-mesh-vpn-fastd +gluon-simple-tc
+  DEPENDS:=gluon-config-mode-core-virtual +gluon-mesh-vpn-fastd
 endef
 
 define Build/Prepare
@@ -33,4 +33,4 @@ define Package/ffho-config-mode-mesh-vpn/install
 	$(call GluonInstallI18N,ffho-config-mode-mesh-vpn,$(1))
 endef
 
-$(eval $(call BuildPackage,ffho-config-mode-mesh-vpn))
+$(eval $(call BuildPackage,ffho-config-mode-mesh-vpn))

+ 1 - 6
ffho/ffho-config-mode-mesh-vpn/files/lib/gluon/config-mode/reboot/0100-mesh-vpn.lua

@@ -13,12 +13,7 @@ else
   local hostname = uci:get_first("system", "system", "hostname")
   local contact = uci:get_first("gluon-node-info", "owner", "contact")
 
-  local msg = [[<p>]] .. i18n.translate('gluon-config-mode:pubkey') .. [[</p>
-               <div class="the-key">
-                 # <%= hostname %>
-                 <br/>
-               <%= pubkey %>
-               </div>]]
+  local msg = i18n.translate('gluon-config-mode:pubkey')
 
   return function ()
            luci.template.render_string(msg, { pubkey=pubkey

+ 10 - 10
ffho/ffho-config-mode-mesh-vpn/files/lib/gluon/config-mode/wizard/0300-mesh-vpn.lua

@@ -21,18 +21,18 @@ function M.section(form)
 
   o = s:option(cbi.Flag, "_limit_enabled", i18n.translate("Limit bandwidth"))
   o:depends("_meshvpn", "1")
-  o.default = uci:get_bool("gluon-simple-tc", "mesh_vpn", "enabled") and o.enabled or o.disabled
+  o.default = uci:get_bool("simple-tc", "mesh_vpn", "enabled") and o.enabled or o.disabled
   o.rmempty = false
 
   o = s:option(cbi.Value, "_limit_ingress", i18n.translate("Downstream (kbit/s)"))
   o:depends("_limit_enabled", "1")
-  o.value = uci:get("gluon-simple-tc", "mesh_vpn", "limit_ingress")
+  o.value = uci:get("simple-tc", "mesh_vpn", "limit_ingress")
   o.rmempty = false
   o.datatype = "integer"
 
   o = s:option(cbi.Value, "_limit_egress", i18n.translate("Upstream (kbit/s)"))
   o:depends("_limit_enabled", "1")
-  o.value = uci:get("gluon-simple-tc", "mesh_vpn", "limit_egress")
+  o.value = uci:get("simple-tc", "mesh_vpn", "limit_egress")
   o.rmempty = false
   o.datatype = "integer"
 end
@@ -44,20 +44,20 @@ function M.handle(data)
 
   -- checks for nil needed due to o:depends(...)
   if data._limit_enabled ~= nil then
-    uci:set("gluon-simple-tc", "mesh_vpn", "interface")
-    uci:set("gluon-simple-tc", "mesh_vpn", "enabled", data._limit_enabled)
-    uci:set("gluon-simple-tc", "mesh_vpn", "ifname", "mesh-vpn")
+    uci:set("simple-tc", "mesh_vpn", "interface")
+    uci:set("simple-tc", "mesh_vpn", "enabled", data._limit_enabled)
+    uci:set("simple-tc", "mesh_vpn", "ifname", "mesh-vpn")
 
     if data._limit_ingress ~= nil then
-      uci:set("gluon-simple-tc", "mesh_vpn", "limit_ingress", data._limit_ingress)
+      uci:set("simple-tc", "mesh_vpn", "limit_ingress", data._limit_ingress)
     end
 
     if data._limit_egress ~= nil then
-      uci:set("gluon-simple-tc", "mesh_vpn", "limit_egress", data._limit_egress)
+      uci:set("simple-tc", "mesh_vpn", "limit_egress", data._limit_egress)
     end
 
-    uci:commit("gluon-simple-tc")
-    uci:commit("gluon-simple-tc")
+    uci:commit("simple-tc")
+    uci:commit("simple-tc")
   end
 end
 

+ 36 - 0
ffho/ffho-config-mode-mesh-vpn/i18n/fr.po

@@ -0,0 +1,36 @@
+msgid ""
+msgstr ""
+"Content-Type: text/plain; charset=UTF-8\n"
+"Project-Id-Version: PACKAGE VERSION\n"
+"PO-Revision-Date: 2015-08-12 23:30+0100\n"
+"Last-Translator:Tobias Bernot <tqbs@airmail.cc>\n"
+"Language-Team: French\n"
+"Language: fr\n"
+"MIME-Version: 1.0\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
+msgid "Downstream (kbit/s)"
+msgstr "Débit déscendant (kbit/s)"
+
+msgid "Limit bandwidth"
+msgstr "Limiter la bande passante"
+
+msgid "Upstream (kbit/s)"
+msgstr "Débit ascendant (kbit/s)"
+
+msgid "Use internet connection (mesh VPN)"
+msgstr "Utiliser la connection internet (Mesh-VPN)"
+
+msgid ""
+"Your internet connection can be used to establish an encrypted connection "
+"with other nodes. Enable this option if there are no other nodes reachable "
+"over WLAN in your vicinity or you want to make a part of your connection's "
+"bandwidth available for the network. You can limit how much bandwidth the "
+"node will use at most."
+msgstr ""
+"Votre nœud peut partager votre accès internet grâce une communication encryptée "
+"avec d'autres nœuds. Vous pouvez limiter la bande passante utilisée par ceci. "
+"Active cette option, si vous n'avez pas d'autres nœuds atteignables par WLAN " 
+"ou si vous voulez partager votre bande passante pour le réseau MESH."
+