Browse Source

split some packages
split ffho-config-mode-site-select in:
- ffho-config-mode-site-select (for the UI, needs ffho-site-generate)
- ffho-site-generate (for the site-generation)
- ffho-upgrade-tools (for migration-scripts)

split ffho-config-mode-geo-location in:
- ffho-config-mode-geo-location
- ffho-upgrade-tools (for migration-scripts)

Karsten Böddeker 8 years ago
parent
commit
3342fdda0a

+ 1 - 1
ffho/ffho-config-mode-site-select/Makefile

@@ -14,6 +14,7 @@ define Package/ffho-config-mode-site-select
   SECTION:=gluon
   CATEGORY:=Gluon
   TITLE:=UI for changing the node-config
+  DEPENDS:=ffho-site-generate
 endef
 
 define Build/Prepare
@@ -29,7 +30,6 @@ endef
 
 define Package/ffho-config-mode-site-select/install
 	$(CP) ./files/* $(1)/
-	$(CP) $(GLUON_SITEDIR)/extra/* $(1)/lib/gluon/site-select/
 	$(call GluonInstallI18N,ffho-config-mode-site-select,$(1))
 endef
 

+ 42 - 0
ffho/ffho-site-generate/Makefile

@@ -0,0 +1,42 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ffho-site-generate
+PKG_VERSION:=1
+PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ffho-site-generate
+  SECTION:=ffho
+  CATEGORY:=Gluon
+  TITLE:=
+  DEPENDS:=+gluon-core +busybox
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
+endef
+
+define Package/ffho-site-generate/description
+endef
+
+define Build/Prepare
+	mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/ffho-site-generate/preinst
+endef
+
+define Package/ffho-site-generate/install
+  $(CP) ./files/* $(1)/
+  $(CP) $(GLUON_SITEDIR)/extra/* $(1)/lib/gluon/site-select/
+endef
+
+$(eval $(call BuildPackage,ffho-site-generate))

+ 0 - 0
ffho/ffho-config-mode-site-select/files/etc/config/currentsite → ffho/ffho-site-generate/files/etc/config/currentsite


+ 0 - 0
ffho/ffho-config-mode-site-select/files/lib/gluon/site-select/site-upgrade → ffho/ffho-site-generate/files/lib/gluon/site-select/site-upgrade


+ 0 - 0
ffho/ffho-config-mode-site-select/files/lib/gluon/upgrade/002-set-site-config → ffho/ffho-site-generate/files/lib/gluon/upgrade/005-set-site-config


+ 0 - 0
ffho/ffho-config-mode-site-select/files/usr/lib/lua/gluon/sites.lua → ffho/ffho-site-generate/files/usr/lib/lua/gluon/sites.lua


+ 43 - 0
ffho/ffho-upgrade-tools/Makefile

@@ -0,0 +1,43 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ffho-upgrade-tools
+PKG_VERSION:=1
+PKG_RELEASE:=$(GLUON_VERSION).$(GLUON_SITE_CODE)-$(GLUON_RELEASE).$(GLUON_CONFIG_VERSION)
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ffho-upgrade-tools
+  SECTION:=ffho
+  CATEGORY:=Gluon
+  TITLE:=Toolset of scripts that support the migration from one ffho-firmware to another.
+  DEPENDS:=+gluon-core +busybox
+  MAINTAINER:=Freifunk Hochstift <maschinenraum@paderborn.freifunk.net>
+  URL:=https://git.c3pb.de/freifunk-pb/ffho-packages
+  SOURCE:=git@git.c3pb.de:freifunk-pb/ffho-packages.git
+endef
+
+define Package/ffho-upgrade-tools/description
+	A collection of scripts that fix and cleanup configurations on a node
+	when upgrading the firmware.
+endef
+
+define Build/Prepare
+	mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/ffho-upgrade-tools/preinst
+endef
+
+define Package/ffho-upgrade-tools/install
+  $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,ffho-upgrade-tools))

+ 0 - 0
ffho/ffho-config-mode-geo-location/files/lib/gluon/upgrade/999-delete-altitude.lua → ffho/ffho-upgrade-tools/files/lib/gluon/upgrade/999-delete-altitude


+ 0 - 0
ffho/ffho-config-mode-site-select/files/lib/gluon/upgrade/999-remove-sysupgrade-currentsite → ffho/ffho-upgrade-tools/files/lib/gluon/upgrade/999-remove-sysupgrade-currentsite